package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)is_granted\((\[(.*?)\])`)
var str = `excludeIf = "expr(object.job === null or not is_granted(['VIEW', object.job]))"
excludeIf = "expr(object.job === null or not is_granted(['VIEW']))"
excludeIf = "expr(not is_granted(['VIEW_TASKS, object.site']) and not is_granted(['SITE_PERMISSION_VIEW_TASKS', object.asset.getSite()]))",
* excludeIf = "expr(not is_granted(['SITE_PERMISSION_NOTIFY_UPDATES']) and not is_granted(['OPERATIVE_PERMISSION_NOTIFY_UPDATES', object.job.getServiceProvider()]))",
$this->type = strtolower(preg_replace('/([a-z])([A-Z])/', '$1_$2', $reflection->getShortName()));`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}