use strict;
my $str = 'excludeIf = "expr(object.job === null or not is_granted([\'VIEW\', object.job]))"
excludeIf = "expr(object.job === null or not is_granted([\'VIEW\']))"
excludeIf = "expr(not is_granted([\'VIEW_TASKS, object.site\']) and not is_granted([\'SITE_PERMISSION_VIEW_TASKS\', object.asset.getSite()]))",
* excludeIf = "expr(not is_granted([\'SITE_PERMISSION_NOTIFY_UPDATES\']) and not is_granted([\'OPERATIVE_PERMISSION_NOTIFY_UPDATES\', object.job.getServiceProvider()]))",
$this->type = strtolower(preg_replace(\'/([a-z])([A-Z])/\', \'$1_$2\', $reflection->getShortName()));';
my $regex = qr/is_granted\((\[(.*?)\])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}