import Foundation
let pattern = #"(?<=--path[ |=])dist\/.*(?=$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// should match
C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js --path dist/libs/lib3
C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js --path=dist/libs/lib3
C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js --path=dist/apps/app1
/nodejs/node.exe ~/projects/angular-tailwind-storybook-nx/tools/scripts/remove-dir.js --path=dist/apps/app1
// should not match
C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js --path apps/app1
C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js path=dist/libs/lib3
C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js path dist/libs/lib3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)