import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=--path[ |=])dist\\/.*(?=$)";
final String string = "// should match\n"
+ "C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path dist/libs/lib3\n"
+ "C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path=dist/libs/lib3\n"
+ "C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path=dist/apps/app1\n"
+ "/nodejs/node.exe ~/projects/angular-tailwind-storybook-nx/tools/scripts/remove-dir.js --path=dist/apps/app1\n\n"
+ "// should not match\n"
+ "C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path apps/app1\n"
+ "C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js path=dist/libs/lib3\n"
+ "C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js path dist/libs/lib3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}