#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=--path[ |=])dist\/.*(?=$)"
Local $sString = "// should match" & @CRLF & _
"C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js --path dist/libs/lib3" & @CRLF & _
"C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js --path=dist/libs/lib3" & @CRLF & _
"C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js --path=dist/apps/app1" & @CRLF & _
"/nodejs/node.exe ~/projects/angular-tailwind-storybook-nx/tools/scripts/remove-dir.js --path=dist/apps/app1" & @CRLF & _
"" & @CRLF & _
"// should not match" & @CRLF & _
"C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js --path apps/app1" & @CRLF & _
"C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js path=dist/libs/lib3" & @CRLF & _
"C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js path dist/libs/lib3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")