const regex = /(?<=--path[ |=])dist\/.*(?=$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=--path[ |=])dist\\\/.*(?=$)', 'gm')
const str = `// should match
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path dist/libs/lib3
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path=dist/libs/lib3
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path=dist/apps/app1
/nodejs/node.exe ~/projects/angular-tailwind-storybook-nx/tools/scripts/remove-dir.js --path=dist/apps/app1
// should not match
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path apps/app1
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js path=dist/libs/lib3
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js path dist/libs/lib3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}