re = /(?<=--path[ |=])dist\/.*(?=$)/m
str = '// should match
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path dist/libs/lib3
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path=dist/libs/lib3
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path=dist/apps/app1
/nodejs/node.exe ~/projects/angular-tailwind-storybook-nx/tools/scripts/remove-dir.js --path=dist/apps/app1
// should not match
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path apps/app1
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js path=dist/libs/lib3
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js path dist/libs/lib3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end