use strict;
my $str = '// should match
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path dist/libs/lib3
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path=dist/libs/lib3
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path=dist/apps/app1
/nodejs/node.exe ~/projects/angular-tailwind-storybook-nx/tools/scripts/remove-dir.js --path=dist/apps/app1
// should not match
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js --path apps/app1
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js path=dist/libs/lib3
C:\\Program Files\\nodejs\\node.exe E:\\marckassay\\angular-tailwind-nx\\tools\\scripts\\remove-dir.js path dist/libs/lib3';
my $regex = qr/(?<=--path[ |=])dist\/.*(?=$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}