using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=--path[ |=])dist\/.*(?=$)";
string input = @"// should match
C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js --path dist/libs/lib3
C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js --path=dist/libs/lib3
C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js --path=dist/apps/app1
/nodejs/node.exe ~/projects/angular-tailwind-storybook-nx/tools/scripts/remove-dir.js --path=dist/apps/app1
// should not match
C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js --path apps/app1
C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js path=dist/libs/lib3
C:\Program Files\nodejs\node.exe E:\marckassay\angular-tailwind-nx\tools\scripts\remove-dir.js path dist/libs/lib3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}