import Foundation
let pattern = #""[^"]*"|'[^'\r\n]*'|[^;\r\n]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
registar.rs;"Rese
rved";Uprava za zajednicke poslove republickih organa
registri.rs;Active;CRI DOMAINS
sbra.rs;Active;CRI DOMAINS
automotiveserbia.rs;Reserved;Uprava za, zajednicke poslove republickih organa
businessinserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
export.rs;Reserved;Uprava za zajednicke poslove republickih organa
exportserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
fdi.rs;Reserved;Uprava za zajednicke poslove republickih organa
ictserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
invest.rs;Reserved;Uprava za zajednicke poslove republickih organa
investicije.rs;Reserved;Uprava za zajednicke poslove republickih organa
investinserbia.rs;Active;Eunet d.o.o.
izvoz.rs;Reserved;Uprava za zajednicke poslove republickih organa
organicserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)