use strict;
my $str = 'registar.rs;"Rese
rved";Uprava za zajednicke poslove republickih organa
registri.rs;Active;CRI DOMAINS
sbra.rs;Active;CRI DOMAINS
automotiveserbia.rs;Reserved;Uprava za, zajednicke poslove republickih organa
businessinserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
export.rs;Reserved;Uprava za zajednicke poslove republickih organa
exportserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
fdi.rs;Reserved;Uprava za zajednicke poslove republickih organa
ictserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
invest.rs;Reserved;Uprava za zajednicke poslove republickih organa
investicije.rs;Reserved;Uprava za zajednicke poslove republickih organa
investinserbia.rs;Active;Eunet d.o.o.
izvoz.rs;Reserved;Uprava za zajednicke poslove republickih organa
organicserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
';
my $regex = qr/"[^"]*"|'[^'\r\n]*'|[^;\r\n]*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}