import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[^\"]*\"|'[^'\\r\\n]*'|[^;\\r\\n]*";
final String string = "registar.rs;\"Rese\n"
+ "rved\";Uprava za zajednicke poslove republickih organa\n"
+ "registri.rs;Active;CRI DOMAINS\n"
+ "sbra.rs;Active;CRI DOMAINS\n"
+ "automotiveserbia.rs;Reserved;Uprava za, zajednicke poslove republickih organa\n"
+ "businessinserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
+ "export.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
+ "exportserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
+ "fdi.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
+ "ictserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
+ "invest.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
+ "investicije.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
+ "investinserbia.rs;Active;Eunet d.o.o.\n"
+ "izvoz.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
+ "organicserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}