// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""[^"]*"|'[^'\r\n]*'|[^;\r\n]*"#).unwrap();
let string = "registar.rs;\"Rese
rved\";Uprava za zajednicke poslove republickih organa
registri.rs;Active;CRI DOMAINS
sbra.rs;Active;CRI DOMAINS
automotiveserbia.rs;Reserved;Uprava za, zajednicke poslove republickih organa
businessinserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
export.rs;Reserved;Uprava za zajednicke poslove republickih organa
exportserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
fdi.rs;Reserved;Uprava za zajednicke poslove republickih organa
ictserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
invest.rs;Reserved;Uprava za zajednicke poslove republickih organa
investicije.rs;Reserved;Uprava za zajednicke poslove republickih organa
investinserbia.rs;Active;Eunet d.o.o.
izvoz.rs;Reserved;Uprava za zajednicke poslove republickih organa
organicserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}