const regex = /"[^"]*"|'[^'\r\n]*'|[^;\r\n]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^"]*"|\'[^\'\\r\\n]*\'|[^;\\r\\n]*', 'g')
const str = `registar.rs;"Rese
rved";Uprava za zajednicke poslove republickih organa
registri.rs;Active;CRI DOMAINS
sbra.rs;Active;CRI DOMAINS
automotiveserbia.rs;Reserved;Uprava za, zajednicke poslove republickih organa
businessinserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
export.rs;Reserved;Uprava za zajednicke poslove republickih organa
exportserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
fdi.rs;Reserved;Uprava za zajednicke poslove republickih organa
ictserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
invest.rs;Reserved;Uprava za zajednicke poslove republickih organa
investicije.rs;Reserved;Uprava za zajednicke poslove republickih organa
investinserbia.rs;Active;Eunet d.o.o.
izvoz.rs;Reserved;Uprava za zajednicke poslove republickih organa
organicserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}