# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"[^\"]*\"|'[^'\r\n]*'|[^;\r\n]*"
test_str = ("registar.rs;\"Rese\n"
"rved\";Uprava za zajednicke poslove republickih organa\n"
"registri.rs;Active;CRI DOMAINS\n"
"sbra.rs;Active;CRI DOMAINS\n"
"automotiveserbia.rs;Reserved;Uprava za, zajednicke poslove republickih organa\n"
"businessinserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
"export.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
"exportserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
"fdi.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
"ictserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
"invest.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
"investicije.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
"investinserbia.rs;Active;Eunet d.o.o.\n"
"izvoz.rs;Reserved;Uprava za zajednicke poslove republickih organa\n"
"organicserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.