$re = '/"[^"]*"|\'[^\'\r\n]*\'|[^;\r\n]*/';
$str = 'registar.rs;"Rese
rved";Uprava za zajednicke poslove republickih organa
registri.rs;Active;CRI DOMAINS
sbra.rs;Active;CRI DOMAINS
automotiveserbia.rs;Reserved;Uprava za, zajednicke poslove republickih organa
businessinserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
export.rs;Reserved;Uprava za zajednicke poslove republickih organa
exportserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
fdi.rs;Reserved;Uprava za zajednicke poslove republickih organa
ictserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
invest.rs;Reserved;Uprava za zajednicke poslove republickih organa
investicije.rs;Reserved;Uprava za zajednicke poslove republickih organa
investinserbia.rs;Active;Eunet d.o.o.
izvoz.rs;Reserved;Uprava za zajednicke poslove republickih organa
organicserbia.rs;Reserved;Uprava za zajednicke poslove republickih organa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);