import Foundation
let pattern = #"GLOBAL_DATA\(([^)]*)\)(.*?)\};"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
//
// GameSettingData.h
// LowpolyJigsaw
//
// Created by Loc Nguyen on 8/4/17.
//
//
#ifndef GameSettingData_h
#define GameSettingData_h
#include "GameCore/GameData/DataMacro.h"
enum class GameSpeed
{
Slow,
Normal,
Fast
};
struct Address
{
DATA(std::string, streetName, "");
DATA(std::string, houseNumber, "");
DATA(std::string, address, "");
};
struct GLOBAL_DATA(GameSettingData)
{
GameSettingData()
{
address = new Address();
address->streetName = "No Trang Long";
address->houseNumber = "13";
}
DATA(bool, isSoundEnable, true);
DATA(bool, isMusicEnable, true);
DATA(GameSpeed, gameSpeed, GameSpeed::Slow);
DATA(Address*, address, "");
};
struct GLOBAL_DATA(GameSettingData)
{
GameSettingData()
{
address = new Address();
address->streetName = "No Trang Long";
address->houseNumber = "13";
}
DATA(bool, isSoundEnable, true);
DATA(bool, isMusicEnable, true);
DATA(GameSpeed, gameSpeed, GameSpeed::Slow);
DATA(Address*, address, "");
};
#endif /* GameSettingData_h */
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)