import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "GLOBAL_DATA\\(([^)]*)\\)(.*?)\\};";
final String string = "//\n"
+ "// GameSettingData.h\n"
+ "// LowpolyJigsaw\n"
+ "//\n"
+ "// Created by Loc Nguyen on 8/4/17.\n"
+ "//\n"
+ "//\n\n"
+ "#ifndef GameSettingData_h\n"
+ "#define GameSettingData_h\n\n"
+ "#include \"GameCore/GameData/DataMacro.h\"\n\n"
+ "enum class GameSpeed\n"
+ "{\n"
+ " Slow,\n"
+ " Normal,\n"
+ " Fast\n"
+ "};\n\n"
+ "struct Address\n"
+ "{\n"
+ " DATA(std::string, streetName, \"\");\n"
+ " DATA(std::string, houseNumber, \"\");\n"
+ " DATA(std::string, address, \"\");\n"
+ "};\n\n"
+ "struct GLOBAL_DATA(GameSettingData)\n"
+ "{\n"
+ " GameSettingData()\n"
+ " {\n"
+ " address = new Address();\n"
+ " address->streetName = \"No Trang Long\";\n"
+ " address->houseNumber = \"13\";\n"
+ " }\n"
+ " \n"
+ " DATA(bool, isSoundEnable, true);\n"
+ " DATA(bool, isMusicEnable, true);\n"
+ " DATA(GameSpeed, gameSpeed, GameSpeed::Slow);\n"
+ " DATA(Address*, address, \"\");\n"
+ "};\n\n\n"
+ "struct GLOBAL_DATA(GameSettingData)\n"
+ "{\n"
+ " GameSettingData()\n"
+ " {\n"
+ " address = new Address();\n"
+ " address->streetName = \"No Trang Long\";\n"
+ " address->houseNumber = \"13\";\n"
+ " }\n"
+ " \n"
+ " DATA(bool, isSoundEnable, true);\n"
+ " DATA(bool, isMusicEnable, true);\n"
+ " DATA(GameSpeed, gameSpeed, GameSpeed::Slow);\n"
+ " DATA(Address*, address, \"\");\n"
+ "};\n"
+ "#endif /* GameSettingData_h */\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}