package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)GLOBAL_DATA\(([^)]*)\)(.*?)\};`)
var str = `//
// GameSettingData.h
// LowpolyJigsaw
//
// Created by Loc Nguyen on 8/4/17.
//
//
#ifndef GameSettingData_h
#define GameSettingData_h
#include "GameCore/GameData/DataMacro.h"
enum class GameSpeed
{
Slow,
Normal,
Fast
};
struct Address
{
DATA(std::string, streetName, "");
DATA(std::string, houseNumber, "");
DATA(std::string, address, "");
};
struct GLOBAL_DATA(GameSettingData)
{
GameSettingData()
{
address = new Address();
address->streetName = "No Trang Long";
address->houseNumber = "13";
}
DATA(bool, isSoundEnable, true);
DATA(bool, isMusicEnable, true);
DATA(GameSpeed, gameSpeed, GameSpeed::Slow);
DATA(Address*, address, "");
};
struct GLOBAL_DATA(GameSettingData)
{
GameSettingData()
{
address = new Address();
address->streetName = "No Trang Long";
address->houseNumber = "13";
}
DATA(bool, isSoundEnable, true);
DATA(bool, isMusicEnable, true);
DATA(GameSpeed, gameSpeed, GameSpeed::Slow);
DATA(Address*, address, "");
};
#endif /* GameSettingData_h */
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}