$re = '/GLOBAL_DATA\(([^)]*)\)(.*?)\};/s';
$str = '//
// GameSettingData.h
// LowpolyJigsaw
//
// Created by Loc Nguyen on 8/4/17.
//
//
#ifndef GameSettingData_h
#define GameSettingData_h
#include "GameCore/GameData/DataMacro.h"
enum class GameSpeed
{
Slow,
Normal,
Fast
};
struct Address
{
DATA(std::string, streetName, "");
DATA(std::string, houseNumber, "");
DATA(std::string, address, "");
};
struct GLOBAL_DATA(GameSettingData)
{
GameSettingData()
{
address = new Address();
address->streetName = "No Trang Long";
address->houseNumber = "13";
}
DATA(bool, isSoundEnable, true);
DATA(bool, isMusicEnable, true);
DATA(GameSpeed, gameSpeed, GameSpeed::Slow);
DATA(Address*, address, "");
};
struct GLOBAL_DATA(GameSettingData)
{
GameSettingData()
{
address = new Address();
address->streetName = "No Trang Long";
address->houseNumber = "13";
}
DATA(bool, isSoundEnable, true);
DATA(bool, isMusicEnable, true);
DATA(GameSpeed, gameSpeed, GameSpeed::Slow);
DATA(Address*, address, "");
};
#endif /* GameSettingData_h */
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);