using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"GLOBAL_DATA\(([^)]*)\)(.*?)\};";
string input = @"//
// GameSettingData.h
// LowpolyJigsaw
//
// Created by Loc Nguyen on 8/4/17.
//
//
#ifndef GameSettingData_h
#define GameSettingData_h
#include ""GameCore/GameData/DataMacro.h""
enum class GameSpeed
{
Slow,
Normal,
Fast
};
struct Address
{
DATA(std::string, streetName, "");
DATA(std::string, houseNumber, "");
DATA(std::string, address, "");
};
struct GLOBAL_DATA(GameSettingData)
{
GameSettingData()
{
address = new Address();
address->streetName = ""No Trang Long"";
address->houseNumber = ""13"";
}
DATA(bool, isSoundEnable, true);
DATA(bool, isMusicEnable, true);
DATA(GameSpeed, gameSpeed, GameSpeed::Slow);
DATA(Address*, address, "");
};
struct GLOBAL_DATA(GameSettingData)
{
GameSettingData()
{
address = new Address();
address->streetName = ""No Trang Long"";
address->houseNumber = ""13"";
}
DATA(bool, isSoundEnable, true);
DATA(bool, isMusicEnable, true);
DATA(GameSpeed, gameSpeed, GameSpeed::Slow);
DATA(Address*, address, "");
};
#endif /* GameSettingData_h */
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}