# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(SYS_FBA_)([A-Z_])+?([A-Z_1-9])*_([0-9]{5,6})"
test_str = ("SYS_FBA_TCRV_IDX1_36953\n"
"SYS_FBA_TCRV_36953")
subst = "\\1HIST_\\4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.