import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(SYS_FBA_)([A-Z_])+?([A-Z_1-9])*_([0-9]{5,6})";
final String string = "SYS_FBA_TCRV_IDX1_36953\n"
+ "SYS_FBA_TCRV_36953";
final String subst = "\\1HIST_\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}