package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(SYS_FBA_)([A-Z_])+?([A-Z_1-9])*_([0-9]{5,6})`)
var str = `SYS_FBA_TCRV_IDX1_36953
SYS_FBA_TCRV_36953`
var substitution = "\1HIST_\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}