using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(SYS_FBA_)([A-Z_])+?([A-Z_1-9])*_([0-9]{5,6})";
string substitution = @"\1HIST_\4";
string input = @"SYS_FBA_TCRV_IDX1_36953
SYS_FBA_TCRV_36953";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}