import Foundation
let pattern = #"^(http:\/\/)?([\da-z\.-]+)([[\/\w \.-]*]*\/?)(\?{1}continue={1})(https?%3A|a)([%=\d\w\.\/-_]*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://dev.finit.io/_ah/login?continue=http%3A%2F%2Fdev.finit.io%2Fh"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}