re = /^(http:\/\/)?([\da-z\.-]+)([[\/\w \.-]*]*\/?)(\?{1}continue={1})(https?%3A|a)([%=\d\w\.\/-_]*)$/
str = 'http://dev.finit.io/_ah/login?continue=http%3A%2F%2Fdev.finit.io%2Fh'
# Print the match result
str.match(re) do |match|
puts match.to_s
end