import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(http:\\/\\/)?([\\da-z\\.-]+)([[\\/\\w \\.-]*]*\\/?)(\\?{1}continue={1})(https?%3A|a)([%=\\d\\w\\.\\/-_]*)$";
final String string = "http://dev.finit.io/_ah/login?continue=http%3A%2F%2Fdev.finit.io%2Fh";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}