const regex = /^(http:\/\/)?([\da-z\.-]+)([[\/\w \.-]*]*\/?)(\?{1}continue={1})(https?%3A|a)([%=\d\w\.\/-_]*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(http:\\\/\\\/)?([\\da-z\\.-]+)([[\\\/\\w \\.-]*]*\\\/?)(\\?{1}continue={1})(https?%3A|a)([%=\\d\\w\\.\\\/-_]*)$', '')
const str = `http://dev.finit.io/_ah/login?continue=http%3A%2F%2Fdev.finit.io%2Fh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}