#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(http:\/\/)?([\da-z\.-]+)([[\/\w \.-]*]*\/?)(\?{1}continue={1})(https?%3A|a)([%=\d\w\.\/-_]*)$"
Local $sString = "http://dev.finit.io/_ah/login?continue=http%3A%2F%2Fdev.finit.io%2Fh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")