// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(http:\/\/)?([\da-z\.-]+)([[\/\w \.-]*]*\/?)(\?{1}continue={1})(https?%3A|a)([%=\d\w\.\/-_]*)$").unwrap();
let string = "http://dev.finit.io/_ah/login?continue=http%3A%2F%2Fdev.finit.io%2Fh";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}