package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(http:\/\/)?([\da-z\.-]+)([[\/\w \.-]*]*\/?)(\?{1}continue={1})(https?%3A|a)([%=\d\w\.\/-_]*)$`)
var str = `http://dev.finit.io/_ah/login?continue=http%3A%2F%2Fdev.finit.io%2Fh`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}