re = /([^\?#]*\w)((?:\/#|#)?)([^\?]*)($|\?.*)/i
str = 'https://demo.wofll.com/#/demo?a=1&b=2'
subst = '$1/index.html$2$3$4'
result = str.sub(re, subst)
# Print the result of the substitution
puts result