import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\?#]*\\w)((?:/#|#)?)([^\\?]*)($|\\?.*)";
final String string = "https://demo.wofll.com/#/demo?a=1&b=2";
final String subst = "$1/index.html$2$3$4";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}