#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?is)([^\?#]*\w)((?:/#|#)?)([^\?]*)($|\?.*)"
Local $sString = "https://demo.wofll.com/#/demo?a=1&b=2"
Local $sSubst = "$1/index.html$2$3$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)