use strict;
my $str = 'https://demo.wofll.com/#/demo?a=1&b=2';
my $regex = qr/([^\?#]*\w)((?:/#|#)?)([^\?]*)($|\?.*)/isp;
my $subst = '$1/index.html$2$3$4';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";