using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\?#]*\w)((?:/#|#)?)([^\?]*)($|\?.*)";
string substitution = @"$1/index.html$2$3$4";
string input = @"https://demo.wofll.com/#/demo?a=1&b=2";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}