const regex = new RegExp('([^\\?#]*\\w)((?:/#|#)?)([^\\?]*)($|\\?.*)', 'is')
const str = `https://demo.wofll.com/#/demo?a=1&b=2`;
const subst = `$1/index.html$2$3$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);