# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\?#]*\w)((?:\/#|#)?)([^\?]*)($|\?.*)/$1\/index.html$2$3$4/is;t' <<< "https://demo.wofll.com/#/demo?a=1&b=2"