re = /1?\(?([0-9]{3})\)?[-.\s]?([0-9]{3})[-.\s]?([0-9]{4})/
str = '11234567890'
subst = '+1($1)-$2-$3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result