# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/1?\(?([0-9]{3})\)?[-.\s]?([0-9]{3})[-.\s]?([0-9]{4})/+1($1)-$2-$3/;t' <<< "11234567890"