using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1?\(?([0-9]{3})\)?[-.\s]?([0-9]{3})[-.\s]?([0-9]{4})";
string substitution = @"+1($1)-$2-$3";
string input = @"11234567890";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}