#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "1?\(?([0-9]{3})\)?[-.\s]?([0-9]{3})[-.\s]?([0-9]{4})"
Local $sString = "11234567890"
Local $sSubst = "+1($1)-$2-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)