use strict;
my $str = '11234567890';
my $regex = qr/1?\(?([0-9]{3})\)?[-.\s]?([0-9]{3})[-.\s]?([0-9]{4})/p;
my $subst = '+1($1)-$2-$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";