package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`1?\(?([0-9]{3})\)?[-.\s]?([0-9]{3})[-.\s]?([0-9]{4})`)
var str = []byte(`11234567890`)
var substitution = []byte("+1($1)-$2-$3")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}