$re = '/(?<=\[)[^\[\]]+(?=\])(?#This matches anything DIRECTLY between two square brackets)/m';
$str = 'abcd[bddb]xyyx
abba[mnop]qrst
abba[mnop[ibbi]abba]qrts
';
$subst = "gaylmao";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;