#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\[)[^\[\]]+(?=\])(?#This matches anything DIRECTLY between two square brackets)"
Local $sString = "abcd[bddb]xyyx" & @CRLF & _
"abba[mnop]qrst" & @CRLF & _
"abba[mnop[ibbi]abba]qrts" & @CRLF & _
""
Local $sSubst = "gaylmao"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)