using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\[)[^\[\]]+(?=\])(?#This matches anything DIRECTLY between two square brackets)";
string substitution = @"gaylmao";
string input = @"abcd[bddb]xyyx
abba[mnop]qrst
abba[mnop[ibbi]abba]qrts
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}