use strict;
my $str = 'abcd[bddb]xyyx
abba[mnop]qrst
abba[mnop[ibbi]abba]qrts
';
my $regex = qr/(?<=\[)[^\[\]]+(?=\])(?#This matches anything DIRECTLY between two square brackets)/mp;
my $subst = 'gaylmao';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";