import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\[)[^\\[\\]]+(?=\\])(?#This matches anything DIRECTLY between two square brackets)";
final String string = "abcd[bddb]xyyx\n"
+ "abba[mnop]qrst\n"
+ "abba[mnop[ibbi]abba]qrts\n";
final String subst = "gaylmao";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}